<% dim ModuleName,InfoID,ChannelShortName,CorrelativeArticle,InstallDir,ChannelDir,Keyword,PageTitle,ArticleIntro,Articlecontent Keyword=stripHTML("思科,3560,交换机,端口限速") PageTitle=stripHTML("思科3560交换机端口限速") ArticleIntro=stripHTML("思科3560交换机端口限速") Articlecontent=stripHTML("   一、网络说明  PC1接在Cisco3550 F0/1上,速率为1M;  PC1接在Cisco3550 F0/2上,速率为2M;  Cisco3550的G…") ModuleName = stripHTML("classical") InfoID = stripHTML("214418") ChannelShortName=stripHTML("文章") InstallDir=stripHTML("http://www.77169.org/") ChannelDir=stripHTML("classical") %> 思科3560交换机端口限速 - 华盟网 - http://www.77169.org  <% Function stripHTML(strHTML) 'Strips the HTML tags from strHTML Dim objRegExp, strOutput Set objRegExp = New Regexp objRegExp.IgnoreCase = True objRegExp.Global = True objRegExp.Pattern = "<.+?>" 'Replace all HTML tag matches with the empty string strOutput = objRegExp.Replace(strHTML, "") 'Replace all < and > with < and > strOutput = Replace(strOutput, "<", "<") strOutput = Replace(strOutput, ">", ">") strOutput = Replace(strOutput,Chr(34),Chr(39)) stripHTML = strOutput 'Return the value of strOutput Set objRegExp = Nothing End Function %> "> 
您现在的位置: 华盟网 >> 知识库 >> 网络原理 >> 交换机 >> 基础教程 >> 正文

[图文]思科3560交换机端口限速

2015/10/20 作者:佚名 来源: 本站原创
导读 <% if len(ArticleIntro)<3 then Response.Write Articlecontent 'Response.Write "Articlecontent" else Response.Write ArticleIntro 'Response.Write "ArticleIntro" end if %>

 

  一、网络说明

  PC1接在Cisco3550 F0/1上,速率为1M;

  PC1接在Cisco3550 F0/2上,速率为2M;

  Cisco3550的G0/1为出口。

  二、详细配置过程

  注:每个接口每个方向只支持一个策略;一个策略可以用于多个接口。因此所有PC的下载速率的限制都应该定义在同一个策略(在本例子当中

  为policy-map user-down),而PC不同速率的区分是在Class-map分别定义。

  1、在交换机上启动QOS

  Switch(config)#mls qos //在交换机上启动QOS

  2、分别定义PC1(10.10.1.1)和PC2(10.10.2.1)访问控制列表

  Switch(config)#access-list 10 permit 10.10.1.0 0.0.0.255 //控制pc1上行流量

  Switch(config)#access-list 100 permit any 10.10.1.0 0.0.0.255 //控制pc1下行流量

  Switch(config)#access-list 11 permit 10.10.2.0 0.0.0.255 //控制pc2上行流量

  Switch(config)#access-list 111 permit any 10.10.2.0 0.0.0.255 //控制pc2下行流量

  3、定义类,并和上面定义的访问控制列表绑定

  Switch(config)# class-map user1-up //定义PC1上行的类,并绑定访问列表10

  Switch(config-cmap)# match access-group 10

  Switch(config-cmap)# exit

  Switch(config)# class-map user2-up

  Switch(config-cmap)# match access-group 11 //定义PC2上行的类,并绑定访问列表10

  Switch(config-cmap)# exit

  Switch(config)# class-map user1-down

  Switch(config-cmap)# match access-group 100 //定义PC1下行的类,并绑定访问列表100

  Switch(config-cmap)# exit

  Switch(config)# class-map user2-down

  Switch(config-cmap)# match access-group 111 //定义PC2下行的类,并绑定访问列表111

  Switch(config-cmap)# exit

  4、定义策略,把上面定义的类绑定到该策略

  Switch(config)# policy-map user1-up //定义PC1上行的速率为1M

  Switch(config-pmap)# class user1-up

  Switch(config-pmap-c)# trust dscp

  Switch(config-pmap-c)# police 1024000 1024000 exceed-action drop

  Switch(config)# policy-map user2-up //定义PC2上行的速率为2M

  Switch(config-pmap)# class user2-up

  Switch(config-pmap-c)# trust dscp

  Switch(config-pmap-c)# police 2048000 1024000 exceed-action drop

  Switch(config)# policy-map user-down

  Switch(config-pmap)# class user1-down

  Switch(config-pmap-c)# trust dscp

  Switch(config-pmap-c)# police 1024000 1024000 exceed-action drop

  Switch(config-pmap-c)# exit

  Switch(config-pmap)# class user2-down

  Switch(config-pmap-c)# trust dscp

  Switch(config-pmap-c)# police 2048000 1024000 exceed-action drop

  Switch(config-pmap-c)# exit

  5、在接口上运用策略

  Switch(config)# interface f0/1

  Switch(config-if)# service-policy input user1-up

  Switch(config)# interface f0/2

  Switch(config-if)# service-policy input user2-up

  Switch(config)# interface g0/1

  Switch(config-if)# service-policy input user-down

                  微信群名称:华盟-黑白之道         华盟--黑白之道⑦QQ群: 9430885

  • 上一篇文章:

  • 下一篇文章: 没有了
  • 
    网友评论
      验证码
     
    

    关注

    分享

    0

    讨论

    2

    猜你喜欢

      <%=CorrelativeArticle%>

    论坛最新贴