cURL/libcURL NTLM连接远程安全限制绕过漏洞(CVE-2015-3143)

怪狗 2016-7-31 Exploit 0 0

cURL/libcURL NTLM连接远程安全限制绕过漏洞(CVE-2015-3143)

发布日期:2015-04-22
更新日期:2015-05-10
受影响系统:
cURL cURL 7.10.6 - 7.41.0

描述:

BUGTRAQ ID: 74299
CVE(CAN) ID: CVE-2015-3143
cURL/libcURL是命令行传输文件工具,支持FTP、FTPS、HTTP、HTTPS、GOPHER、TELNET、DICT、FILE和LDAP。
cURL及libcurl 7.10.6-7.41.0版本,没有正确重新使用ntlm连接,这可使远程攻击者通过未经验证的请求,以其他身份连接。
<*来源:Paras Sethia
*>
建议:
厂商补丁:
cURL
----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://curl.haxx.se/docs/adv_20150422A.html
http://www.debian.org/security/2015/dsa-3232
http://www.ubuntu.com/usn/USN-2591-1

Ubuntu 用户安装下载器 cURL 7.36.0 http://www.linuxidc.com/Linux/2014-05/102269.htm

Linux curl使用简单介绍 http://www.codesec.net/Linux/2008-01/10891.htm

Unix下Curl的使用方法及常用功能记录分享 http://www.codesec.net/Linux/2012-08/69154.htm

curl命令使用 http://www.codesec.net/Linux/2014-09/107018.htm

原文地址:http://www.77169.com/exploits/2015/20150514011629.shtm

转载请注明来自华盟网,本文标题:《cURL/libcURL NTLM连接远程安全限制绕过漏洞(CVE-2015-3143)》

喜欢 (0) 发布评论