JoomlaVS – 黑盒子Ruby Powered,Joomla漏洞扫描器

华盟学院山东省第二期线下学习计划

 

JoomlaVS是一款黑盒子,Ruby支持的应用程序,可以帮助自动评估Joomla安装的易用性。它支持基本的指纹识别,可以扫描组件,模块和模板中的漏洞以及Joomla本身内存在的漏洞。

安装

到目前为止,JoomlaVS仅在Debian上进行过测试,但在大多数操作系统中安装过程应该是相似的。

1.确保系统上安装了Ruby [2.2.6或更高版本]
2.使用git clone克隆源代码https://github.com/rastating/joomlavs.git
3.使用sudo gem install bundler && bundle install来安装bundler和所需的gems

如果您在安装JoomlaVS的依赖关系(特别是Nokogiri)时遇到问题,请首先确保您拥有编译C扩展所需的所有工具:
sudo apt-get install build-essential补丁

您的系统上可能没有安装重要的开发头文件。如果您发现自己处于这种情况,那么您应该这样做:
sudo apt-get install ruby??-dev zlib1g-dev liblzma-dev libcurl4-openssl-dev

如何使用JoomlaVS
唯一需要的选项是-u / --url 选项,它指定了要定位的地址。然而,要进行全面扫描,还应该指定--scan-all选项,例如ruby joomlavs.rb -u yourjoomlatarget.com --scan-all。

完整的选项列表可以在下面找到:
用法:joomlavs.rb [选项]
基本选项
-u,--url要扫描的Joomla URL /域。
--basic-auth <用户名:密码>基本的HTTP认证凭证
-v,--verbose启用详细模式

枚举选项
-a,--scan-all扫描所有易受攻击的扩展
-c,--scan-components扫描易受攻击的组件
-m,--scan-modules扫描易受攻击的模块
-t,--scan-templates扫描易受攻击的模板
-q,--quiet仅使用被动方法进行扫描

高级选项
- 关注重定向自动遵循重定向
- 无颜色在输出中禁用颜色
--proxy <[protocol://] host:port> HTTP,SOCKS4 SOCKS4A和SOCKS5
被支持。如果没有协议,HTTP将被使用
--proxy-auth <用户名:密码>代理身份验证凭据
--threads多线程请求时使用的线程数
--user-agent与所有请求一起发送的用户代理字符串

下载地址:https://github.com/rastating/joomlavs

www.idc126.com

仅供于学习研究使用,不得非法使用,如非法操作,责任自行承担

文章出处:http://www.effecthacking.com,由华盟网翻译排版,转载请注明华盟网

本文由 华盟网 作者:AlexFrankly 发表,其版权均为 华盟网 所有,文章内容系作者个人观点,不代表 华盟网 对观点赞同或支持。如需转载,请注明文章来源。
0

发表评论